Maven Repository


To simplify support and usage of Universa-specific Java code, the Universa Foundation provides the public Maven repository.

Note that to access this repository from Java-based tools (sbt, Maven, Gradle), you may need a fairly recent Java 1.8 installation (consider 1.8_181 or newer) for SSL security to be supported properly.

Universa public Maven repository

Maven

Add the reference to pom.xml of your project:

<project>
    ...
    <repositories>
        <repository>
            <id>universa-repo</id>
            <url>https://maven.universa.io/</url>
        </repository>
    </repositories>
    ...
</project>

Gradle

Add the reference to the build.gradle of your project:

repositories {
  ...
  maven {
    url = "https://maven.universa.io/"
  }
}

SBT

Add the reference to build.sbt of your project:

resolvers += "Universa public Maven repository" at "https://maven.universa.io/"

Or, alternatively:

resolvers += Resolver.url("Universa public Maven repository", url("https://maven.universa.io/"))

Artifacts

The Artifact group is the same for all the Universa artifacts: com.icodici

Provided artifacts are:

  • common_tools – serialisation, database and other tools;
  • crypto – cryptography component;
  • universa_core — main Universa components: Contract, Node etc;
  • uniclient – command-line tool.

Current version (for all the artifacts) is: 3.8.4

Below is the example how to refer the universa_core artifact from your project (normally available at https://maven.universa.io/com/icodici/universa_core/3.8.4/ ).

Maven

<dependency>
    <groupId>com.icodici</groupId>
    <artifactId>universa_core</artifactId>
    <version>3.8.4</version>
</dependency>

Gradle

compile group: 'com.icodici', name: 'universa_core', version: '3.8.4'

SBT

libraryDependencies += "com.icodici" % "universa_core" % "3.8.4"

Ivy

<dependency org="com.icodici" name="universa_core" rev="3.8.4"/>

Grape

@Grapes(
    @Grab(group='com.icodici', module='universa_core', version='3.8.4')
)

Leiningen

[com.icodici/universa_core "3.8.4"]

Buildr

'com.icodici:universa_core:jar:3.8.4'